Riley Apeldoorn
75603bd327
- Move trivial modules to `services.nix` - Gather user-related config in `users.nix` - Move loading of shared home-manager config into `shared/core`
19 lines
405 B
Nix
19 lines
405 B
Nix
# Services that are common and don't require complex configuration. If there are options
|
|
# involved, consider moving the service to its own module.
|
|
|
|
{ ... }: {
|
|
|
|
services.openssh = {
|
|
enable = true;
|
|
settings.PasswordAuthentication = false;
|
|
};
|
|
|
|
services.tailscale = {
|
|
# TODO: configure declaratively
|
|
enable = true;
|
|
interfaceName = "ts0";
|
|
};
|
|
|
|
services.earlyoom.enable = true;
|
|
|
|
}
|