os/shared/core/services.nix
Riley Apeldoorn 75603bd327 Refactor the shared/core namespace
- Move trivial modules to `services.nix`
- Gather user-related config in `users.nix`
- Move loading of shared home-manager config into `shared/core`
2023-06-17 20:48:22 +02:00

19 lines
405 B
Nix

# Services that are common and don't require complex configuration. If there are options
# involved, consider moving the service to its own module.
{ ... }: {
services.openssh = {
enable = true;
settings.PasswordAuthentication = false;
};
services.tailscale = {
# TODO: configure declaratively
enable = true;
interfaceName = "ts0";
};
services.earlyoom.enable = true;
}