Riley Apeldoorn
027bbd01c1
- XDG user directories - Fingerprint reader on `lime` - Enable tailscale - Enable `iamb` on `lime`
23 lines
No EOL
466 B
Nix
23 lines
No EOL
466 B
Nix
{ config, ... }:
|
|
|
|
let homeDir = config.home.homeDirectory;
|
|
|
|
in {
|
|
|
|
xdg.userDirs = {
|
|
# Let Nix manage the XDG directories
|
|
enable = true;
|
|
createDirectories = true;
|
|
# Define the paths
|
|
download = "/tmp";
|
|
music = "${homeDir}/music";
|
|
documents = "${homeDir}/docs";
|
|
pictures = "${homeDir}/pics";
|
|
# Disable generation of these
|
|
desktop = null;
|
|
publicShare = null;
|
|
templates = null;
|
|
videos = null;
|
|
};
|
|
|
|
} |